API JOURNEY: DARI O-PRO
Kata Kunci:
API JOURNEYSinopsis
Siap Memulai Petualangan API Anda?
Di dunia yang saling terhubung, API (Application Programming Interface) adalah sihir di belakang layar. Dari aplikasi smartphone hingga platform web kompleks, API adalah jembatan yang membuat semuanya bekerja. Tapi, bagaimana cara kerjanya? Dan bagaimana Anda bisa membangunnya? “API JOURNEY DARI 0- PRO” adalah panduan Anda.
Buku ini dirancang untuk mengubah Anda dari pemula yang penasaran menjadi developer yang percaya diri dalam merancang, membangun, dan menguji API. Lupakan teori yang membosankan! Seperti tagline kami, buku ini mengajak Anda “SERUNYA MENJELAJAHI DUNIA API DENGAN PROYEK NYATA”.
Dalam Perjalanan Ini, Anda Akan:
- Memulai dari Titik Nol: Membedah tuntas konsep fundamental API, mulai dari arsitektur REST, protokol HTTP, hingga format data esensial seperti JSON.
- Praktek Langsung: Tidak hanya membaca, Anda akan langsung praktek sehingga tidak hanya teori saja
- Membangun API SendList (CRUD): Merancang dan membangun endpoint API Anda sendiri dari awal! Kita akan menggunakan teknologi backend populer seperti Node.js/Express dan Python.
- Cloud (Deployment): Belajar dari studi kasus nyata dan memahami bagaimana mendeploy API Anda ke cloud agar dapat diakses oleh siapa pun, di mana pun.
Siapa yang Harus Ikut Perjalanan Ini?
Buku ini sempurna untuk mahasiswa, peserta bootcamp, frontend developer yang ingin full-stack, atau siapa saja yang siap mengambil langkah dari Nol menjadi Pro di dunia API.
Ikat sabuk pengaman Anda. Perjalanan API Anda dimulai sekarang!
Bab
-
KATA PENGANTAR
-
DAFTAR ISI
-
BAB 1 PENDAHULUAN
-
BAB 2 KONSEP DASAR API
-
BAB 3 TOOLS & CLI UNTUK API
-
BAB 4 MEMBUAT REST API SEDERHANA
-
BAB 5 CRUD API
-
BAB 6 STUDI KASUS API
-
BAB 7 API LANJUTAN
-
BAB 8 KEAMANAN API & BEST PRACTICE
-
BAB 9 INTEGRASI API PIHAK KETIGA
-
BAB 10 TESTING & DOKUMENTASI API
-
BAB 11 CI/CD & DEPLOYMENT API
-
BAB 12 STUDI KASUS AKHIR: PROJECT MINI “SMARTSTORE API”
-
DAFTAR PUSTAKA
-
PROFIL PENULIS
Unduhan
Referensi
Bass, L., Weber, I., & Zhu, L. (2015). DevOps: A software architect's perspective. Addison-Wesley Professional.
Berners-Lee, T., Fielding, R., & Frystyk, H. (1996). Hypertext Transfer Protocol -- HTTP/1.0 (RFC 1945). Internet Engineering Task Force. https://www.rfc-editor.org/rfc/rfc1945
Cerny, T., Donahoo, M. J., & Trnka, M. (2016). Contextual understanding of microservice architecture: Current and future directions. ACM SIGAPP Applied Computing Review, 17(4), 29-45. https://doi.org/10.1145/3051053.3051056
Express.js. (2023). Express.js documentation. https://expressjs.com/
Fielding, R. T. (2000). Architectural styles and the design of network-based software architectures [Doctoral dissertation, University of California, Irvine]. https://www.ics.uci.edu/~fielding/pubs/dissertation/rest_arch_style.htm
Fowler, M., & Lewis, J. (2014). Microservices: A definition of this new architectural term. https://martinfowler.com/articles/microservices.html
GitHub, Inc. (2023). GitHub Actions documentation. https://docs.github.com/en/actions
Google Developers. (2023). Google Maps Platform documentation. https://developers.google.com/maps/documentation
GraphQL Foundation. (2023). GraphQL: A query language for APIs. https://graphql.org/learn/
Hardt, D. (2012). The OAuth 2.0 authorization framework (RFC 6749). Internet Engineering Task Force. https://www.rfc-editor.org/rfc/rfc6749
Humble, J., & Farley, D. (2010). Continuous delivery: Reliable software releases through build, test, and deployment automation. Addison-Wesley Professional.
Jones, M., Bradley, J., & Sakimura, N. (2015). JSON Web Token (JWT) (RFC 7519). Internet Engineering Task Force. https://www.rfc-editor.org/rfc/rfc7519
Masse, M. (2011). REST API design rulebook. O'Reilly Media.
Midtrans. (2023). Midtrans API documentation. https://docs.midtrans.com/
Mozilla Developer Network. (2023). HTTP methods. https://developer.mozilla.org/en-US/docs/Web/HTTP/Methods
Newman, S. (2015). Building microservices: Designing fine-grained systems. O'Reilly Media.
Node.js Foundation. (2023). Node.js documentation. https://nodejs.org/docs/
OWASP Foundation. (2023). OWASP API Security Top 10. https://owasp.org/www-project-api-security/
Pautasso, C., Zimmermann, O., & Leymann, F. (2008). RESTful web services vs. "big" web services: Making the right architectural decision. In Proceedings of the 17th International Conference on World Wide Web (pp. 805-814). ACM. https://doi.org/10.1145/1367497.1367606
Postman, Inc. (2023). Postman learning center. https://learning.postman.com/
Railway Corp. (2023). Railway documentation. https://docs.railway.app/
Render. (2023). Render documentation. https://render.com/docs
Richardson, L., & Ruby, S. (2013). RESTful web APIs. O'Reilly Media.
Swagger/OpenAPI Initiative. (2023). OpenAPI Specification v3.1.0. https://spec.openapis.org/oas/latest.html
Telegram. (2023). Telegram Bot API documentation. https://core.telegram.org/bots/api
Tilkov, S., & Vinoski, S. (2010). Node.js: Using JavaScript to build high-performance network programs. IEEE Internet Computing, 14(6), 80-83. https://doi.org/10.1109/MIC.2010.145
Twilio Inc. (2023). Twilio WhatsApp API documentation. https://www.twilio.com/docs/whatsapp
W3C. (2014). Cross-Origin Resource Sharing (CORS). https://www.w3.org/TR/cors/
Amazon Web Services. (2023). Amazon API Gateway documentation. https://docs.aws.amazon.com/apigateway/
Bass, L., Weber, I., & Zhu, L. (2015). DevOps: A software architect's perspective. Addison-Wesley Professional.
Berners-Lee, T., Fielding, R., & Frystyk, H. (1996). Hypertext Transfer Protocol — HTTP/1.0 (RFC 1945). Internet Engineering Task Force. https://www.rfc-editor.org/rfc/rfc1945
Bhosale, P. (2022). Metrics, logs, and traces: A unified approach to observability in microservices. Journal of Artificial Intelligence, Machine Learning & Data Science, 1(1), 2084-2088. https://urfjournals.org/open-access/metrics-logs-and-traces-a-unified-approach-to-observability-in-microservices.pdf
Cerny, T., Donahoo, M. J., & Trnka, M. (2016). Contextual understanding of microservice architecture: Current and future directions. ACM SIGAPP Applied Computing Review, 17(4), 29-45. https://doi.org/10.1145/3051053.3051056
Docker, Inc. (2023). Docker documentation. https://docs.docker.com/
Domoney, C. (2023). Defending APIs: API security in depth. Packt Publishing.
Express.js. (2023). Express.js documentation. https://expressjs.com/
Fielding, R. T. (2000). Architectural styles and the design of network-based software architectures [Doctoral dissertation, University of California, Irvine]. https://www.ics.uci.edu/~fielding/pubs/dissertation/rest_arch_style.htm
Fowler, M., & Lewis, J. (2014). Microservices: A definition of this new architectural term. https://martinfowler.com/articles/microservices.html
GitHub, Inc. (2023). GitHub Actions documentation. https://docs.github.com/en/actions
Google Developers. (2023). Google Maps Platform documentation. https://developers.google.com/maps/documentation
Grafana Labs. (2023). Grafana documentation. https://grafana.com/docs/
GraphQL Foundation. (2023). GraphQL: A query language for APIs. https://graphql.org/learn/
